Experiencing extended issues on employee portal.
Incident Report for Tuition.io
Resolved
This incident has been resolved.
Posted Sep 16, 2019 - 13:30 PDT
Monitoring
Issue has been fixed. Will be resolved fully within the next 30 minutes.
Posted Sep 16, 2019 - 13:11 PDT
Investigating
Site is in maintenance mode while we recover system. For any urgent issues, please email support@tuition.io
Posted Sep 16, 2019 - 09:55 PDT
This incident affected: Employee Web Portal (Account Linking, Login, Registration) and Employee Mobile Apps (iPhone App, Android App).