Known Issue with Linking FedLoan Accounts
Incident Report for Tuition.io
Resolved
This incident has been resolved.
Posted Apr 18, 2017 - 11:01 PDT
Investigating
We are aware of issues related to linking and refreshing FedLoan student loan accounts. We will provide an update when this is identified and resolved.
Posted Apr 17, 2017 - 10:25 PDT