Known Issue with Linking Navient Accounts
Incident Report for Tuition.io
Resolved
This incident has been resolved.
Posted Mar 23, 2017 - 11:32 PDT
Investigating
We are aware of issues related to linking and refreshing Navient student loan accounts. We will provide an update when this is identified and resolved.
Posted Mar 22, 2017 - 11:34 PDT