Known Issue with Linking ACS Accounts
Incident Report for Tuition.io
Resolved
This incident has been resolved.
Posted Feb 14, 2017 - 16:36 PST
Investigating
We are aware of issues related to linking and refreshing ACS student loan accounts. We will provide an update when this is identified and resolved.
Posted Jan 17, 2017 - 14:55 PST