Resetting password
Incident Report for Tuition.io
Resolved
This incident has been resolved.
Posted Aug 17, 2016 - 09:35 PDT
Investigating
Users are experiencing issues resetting their passwords in Internet Explorer 11.

Known good browsers include Google Chrome, Firefox, and Microsoft Edge. You may also reset your password on a smartphone using its built-in browser.
Posted Aug 11, 2016 - 11:48 PDT