Known Issue with Linking Nelnet Accounts
Incident Report for Tuition.io
Resolved
This incident has been resolved.
Posted Apr 17, 2017 - 17:46 PDT
Investigating
We are aware of issues related to linking and refreshing Nelnet student loan accounts. We will provide an update when this is identified and resolved.
Posted Apr 17, 2017 - 11:17 PDT