Erroneous emails
Incident Report for Tuition.io
Resolved
The issue has been identified and resolved. If you have any questions or concerns, please do not hesitate to reach out to customer service at support@tuition.io.
Posted Dec 05, 2016 - 16:21 PST
Investigating
We are currently investigating reports of erroneous emails being sent to a small group of individuals. Please note that you can safely disregard any emails received from Tuition.io between 5:30p - 6:00p ET. Updates to follow.
Posted Dec 05, 2016 - 15:14 PST